Manual Page Search Parameters

LCD(4) Device Drivers Manual (luna88k) LCD(4)

lcdfront panel LCD display

lcd0 at mainbus0

The lcd driver provides access to the front panel LCD display on LUNA-88K. It is accessed using write(2) to print the characters on the LCD. The device has a physical display area of 16 characters x 2 lines and an internal line buffer of 40 characters x 2 lines.

The following ioctl calls apply to the lcd device:

Clear the LCD screen, restore display area from shift and move the cursor to upper-left position.
Restore display area from shift and move the cursor to upper-left position.
int *
Specify cursor advance direction and display shift mode.
int *
Control display on/off, cursor on/off, and cursor blinking on/off.
int *
Move the cursor or shift the display area.
int *
Move the cursor to the specified position. On the first line, the position is specified by a value between 0x00 and 0x27. On the second line, the value is between 0x40 and 0x67.
Restore boot-time LCD message.

These ioctl parameters are defined in <machine/lcd.h>.

/dev/lcd
 

ioctl(2)

The lcd driver first appeared in OpenBSD 4.1.

February 15, 2015 current